Se você é um desenvolvedor mobile e atualizou seu iPhone ou iPad para versão 9 do iOS, estará recebendo uma mensagem de erro dizendo que o “Desenvolvedor não é confiável” ao executar algum aplicativo instalado via xcode-beta utilizando uma conta free para desenvolvedor (foi nesse cenário que eu recebi a mensagem de erro).

Para resolver esse problema de segurança, procure o ícone: Ajustes -> Geral -> Perfil.

Selecione o perfil que deseja aceitar como Desenvolvedor e basta selecionar a opção como verificado, e pronto, poderá executar aplicativos instalados via XCode assinados com essa conta de desenvolvedor.